大牛?无他,唯手熟尔!

mysql5.7.9报错this is incompatible with sql_mode=only_full_group_by之解决

2015-12-22 16:17:23来源:caogenjava阅读[4048]评论[0]
摘要:之前一直用的是5.6版本的mysql,最近升级到5.7.9之后之前运行挺正常的项目报错:which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by。经过网上一番查找,解决如下。

本文由草根java提供,转载请注明出处https://www.caogenjava.com/detail/71.html

之前一直用的是5.6版本的mysql,最近升级到5.7.9之后之前运行挺正常的项目报错:which is not functionally dependent on columns in GROUP BY clause; this is incompatible with sql_mode=only_full_group_by。经过网上一番查找,解决如下。

我的mysql是部署在linux上的,修改/etc/my.cnf文件:

sql_mode=NO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER

关键是得有这个NO_AUTO_CREATE_USER,修改后重启mysql,运行正常。


除非注明,文章均为草根java原创,转载请注明本文地址: https://www.caogenjava.com/detail/71.html

上一篇:Linux上删除乱码文件之方法        下一篇:朝鲜红星Linux操作系统对国民全面监视
网友评论,共0 发表评论
昵称:
评论:
验证码: 刷新验证码