大牛?无他,唯手熟尔!

Eclipse中Cannot change version of project facet Dynamic web module to 2.5之解决

摘要:使用Eclipse新建的项目有时候会发现无法发布到tomcat6中去,因为你的web module版本是3.0的,版本太高,tomcat6不支持。而其实你的项目使用web module 2.5就足够了,于是尝试将版本降为2.5,但是悲剧来了,Eclipse提示:Cannot change version of project facet Dynamic web module to 2.5。

本文由草根java提供,转载请注明出处https://www.caogenjava.com/detail/104.html

使用Eclipse新建的项目有时候会发现无法发布到tomcat6中去,因为你的web module版本是3.0的,版本太高,tomcat6不支持。而其实你的项目使用web module 2.5就足够了,于是尝试将版本降为2.5,但是悲剧来了,Eclipse提示:Cannot change version of project facet Dynamic web module to 2.5。

QQ截图20181120155146.png

如何解决呢,废话不多说,直接上方案,看图:

QQ截图20181120160637.png

切换到navigator模式,因为只有这样你才能看到.settings文件夹,找到文件org.eclipse.wst.common.project.facet.core.xml,把jst.web对应的version修改为2.5即可。


双11云服务器热购推广(腾讯云):2核+4G内存+3M带宽=688元/3年(仅限新用户)

除非注明,文章均为草根java原创,转载请注明本文地址: https://www.caogenjava.com/detail/104.html

上一篇:java web项目代码不报错但是项目左上角有个红叉之解决        下一篇:以小米6为例图说安卓手机如何安装谷歌四件套
网友评论,共0 发表评论
昵称:
评论:
验证码: 刷新验证码
双11云服务器热购
    购买建议:带宽不用太高了,1M就够用,多考虑内存。